Field Edit + default RST

9 posts / 0 new
Last post
no3m
Field Edit + default RST

When editing any field (Call, Name, QTH, Comments, etc.), after deleting a character, the cursor is moved to the end of the next character. Very difficult to make corrections with cursor moving to unexpected place during edits, especially managing DX pileup, etc.

Also, RST sent and rcvd fields are not being populated with default values set in preferences for New QSO anymore.

CQRlog version 2.0.2 (001) binary version
OS: Archlinux 64-bit

73 Eric NO3M

oh1mrr
I confirm, noticed same..

I confirm, noticed same..

Jarmo

ok7an
ok7an's picture
Re: Field Edit + default RST

Thank you for bug report , Eric. I just fixed that. Now both RST_S and RST_R use default values from Preferences.

I'm sorry I can't reproduce the problem with deleting character. When I use Delete key to delete any character, the cursor stays where it should be :(.

73 Petr, OK2CQR

oh1mrr
In my case cursor jumps one

In my case cursor jumps one letter fwd. If i have call oh1mrr and cursor is beginning of call
I delete "o", cursor jumps right side of "h".

Jarmo

no3m
Yes, the problem is exactly

Yes, the problem is exactly as Jarmo describes. I tried versions back to 2.0.0 and it behaved the same, but somehow I do not remember it acting like that originally when I ran 2.0.0. I wonder if this is something related to the OS or a configuration related bug?

no3m
TEdit field backspace problem - Compiler Problem

Confirmed that this is a compiler related issue with the released binaries.

I downloaded the source and compiled it with FPC 3.0.2 and Lazarus 1.6.4 and the backspace is working normally in the callsign and other fields.

Please consider upgrading the version of Lazarus that is used for creating the binaries, or if not possible due to distribution limitations, trying the patch per the links in my last post.

For now, I'll just use my own compiled version.

73 Eric

no3m
TEdit field backspace problem

Petr

The issue I reported previously appears to be a bug in Lazarus, see here:

https://forum.lazarus.freepascal.org/index.php?topic=35873.0

and bugtracker:

https://bugs.freepascal.org/view.php?id=30596

What is the best way to resolve this in CQRlog?

73 Eric NO3M

oh1mrr
Version 2.1.0 does work ok.

Version 2.1.0 does work ok. Maybe you take that version
in use?

Jarmo

no3m
Version 2.1.0

Jarmo

I had binary version 2.1.0 installed, and still had the problem. Only until I compiled my own binary from the source code it works normal, since it is with a later version of Lazarus which the bug is fixed. If Petr is still using the same older version of Lazarus to compile 2.1.0 as earlier versions, then the problem still exists since it would still have the TEdit bug.