2.0.1 will not install on Mint 17.3

23 posts / 0 new
Last post
NZ0T
2.0.1 will not install on Mint 17.3

I have tried to install new version 2.0.1 from terminal and Update Manager and both get the same error:

(synaptic:5955): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
(Reading database ... 171091 files and directories currently installed.)
Preparing to unpack .../cqrlog_2.0.1-1~trusty_amd64.deb ...
Unpacking cqrlog (2.0.1-1~trusty) over (2.0.0-1~trusty) ...
dpkg: warning: subprocess old post-removal script returned error exit status 1
dpkg: trying script from the new package instead ...
dpkg: error processing archive /var/cache/apt/archives/cqrlog_2.0.1-1~trusty_amd64.deb (--unpack):
subprocess new post-removal script returned error exit status 1
dpkg: error while cleaning up:
subprocess new post-removal script returned error exit status 1
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Errors were encountered while processing:
/var/cache/apt/archives/cqrlog_2.0.1-1~trusty_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:

ea4ta
Same error on Ubuntu 14.04

Same error on Ubuntu 14.04

N2PAD
I get a similar error for ug

I have it installed and running well, but today I got an upgrade notice for ver 2.0.1-1 from software manager. When I tried to install it, get this error:

E: /var/cache/apt/archives/cqrlog_2.0.1-1~trusty_amd64.deb: subprocess new post-removal script returned error exit status 1

Pete

N2PAD
More details:

(synaptic:8309): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
(Reading database ... 187412 files and directories currently installed.)
Preparing to unpack .../cqrlog_2.0.1-1~trusty_amd64.deb ...
Unpacking cqrlog (2.0.1-1~trusty) over (2.0.0-1~trusty) ...
dpkg: warning: subprocess old post-removal script returned error exit status 1
dpkg: trying script from the new package instead ...
dpkg: error processing archive /var/cache/apt/archives/cqrlog_2.0.1-1~trusty_amd64.deb (--unpack):
subprocess new post-removal script returned error exit status 1
dpkg: error while cleaning up:
subprocess new post-removal script returned error exit status 1
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Errors were encountered while processing:
/var/cache/apt/archives/cqrlog_2.0.1-1~trusty_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:

W2PAU
W2PAU's picture
2.0.1 will not install on Mint 17.3 (Exact same errors as N2PAD)

Subject captures it. Exactly what N2PAD sees.

Thank you and 73

Jim - W2PAU

N3MOW
Same problem with Mint 17.1

Same problem updating from Mint 17.1. Have V. 2.0.0(001) running now. Update to 2.0.1-1 Trusty did not complete. Same error messages as in previous posts. What is wrong? Is there a fix?

Marty, N3MOW

Marty, N3MOW

KE7TUB
KE7TUB's picture
Getting same error on Ubuntu 16.04

I tried downloading and installing the .deb and that didn't work either. It won't purge, or remove cqrlog. I can't even install other .deb packages like google chrome, or icon themes because this package has screwed up my system. Trying to fix it using "sudo dpkg --configure -a" and "apt-get install -f" have failed.

sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
cqrlog
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/7,618 kB of archives.
After this operation, 13.3 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 278360 files and directories currently installed.)
Preparing to unpack .../cqrlog_2.0.1-1~xenial_amd64.deb ...
Unpacking cqrlog (2.0.1-1~xenial) over (2.0.0-1~xenial) ...
dpkg: warning: subprocess old post-removal script returned error exit status 1
dpkg: trying script from the new package instead ...
dpkg: error processing archive /var/cache/apt/archives/cqrlog_2.0.1-1~xenial_amd64.deb (--unpack):
subprocess new post-removal script returned error exit status 1
dpkg: error while cleaning up:
subprocess new post-removal script returned error exit status 1
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
/var/cache/apt/archives/cqrlog_2.0.1-1~xenial_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

dk7ob
Me too... (on Kubuntu 16.04)

Ok, it's not a clever subject line, but I see that same error on Kubuntu 16.04.
Since I've just installed Kubuntu 16.04 and still have many issues, I'm glad to see that this problem seems unrelated to Kubuntu.

DK1MAX
Same.. on Ubuntu 16.04 LTS

sudo apt upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden aktualisiert (Upgrade):
cqrlog
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 7.618 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 110 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]
(Lese Datenbank ... 290046 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cqrlog_2.0.1-1~xenial_amd64.deb ...
Entpacken von cqrlog (2.0.1-1~xenial) über (2.0.0-1~trusty) ...
dpkg: Warnung: Unterprozess altes post-removal-Skript gab den Fehlerwert 1 zurück
dpkg: stattdessen wird Skript aus dem neuen Paket probiert ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/cqrlog_2.0.1-1~xenial_amd64.deb (--unpack):
Unterprozess neues post-removal-Skript gab den Fehlerwert 1 zurück
dpkg: Fehler beim Aufräumen:
Unterprozess neues post-removal-Skript gab den Fehlerwert 1 zurück
Trigger für man-db (2.7.5-1) werden verarbeitet ...
Trigger für desktop-file-utils (0.22-1ubuntu5) werden verarbeitet ...
Trigger für mime-support (3.59ubuntu1) werden verarbeitet ...
Trigger für gnome-menus (3.13.3-6ubuntu3) werden verarbeitet ...
Trigger für bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) werden verarbeitet ...
Rebuilding /usr/share/applications/bamf-2.index...
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/cqrlog_2.0.1-1~xenial_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

ok7an
ok7an's picture
Hi guys,

Hi guys,

could you send me what do you have in /etc/apparmor.d/usr.sbin.myqsld and /etc/apparmor.d/local/usr.sbin.myqsld, please?

Quick fix:

gksudo gedit /var/lib/dpkg/status

Find string :

Package: cqrlog

it will find something like this:

Package: cqrlog
Status: install ok installed
Priority: extra
Section: hamradio
Installed-Size: 27053
Maintainer: Debian Hamradio Maintainers
Architecture: amd64
Version: 2.0.1-1~xenial
Depends: libatk1.0-0 (>= 1.12.4), libc6 (>= 2.2.5), libcairo2 (>= 1.2.4), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.12.0), libgtk2.0-0 (>= 2.24.0), libpango-1.0-0 (>= 1.14.0), libx11-6, libssl-dev, mariadb-server | mysql-server, mariadb-client | mysql-client, libhamlib2 (>= 1.2.10), libhamlib-utils (>= 1.2.10), libmysqlclient-dev
Description: Advanced logging program for hamradio operators
CQRLOG is an advanced ham radio logger based on MySQL embedded database.
Provides radio control based on hamlib libraries (currently support of 140+
radio types and models), DX cluster connection, HamQTH/QRZ callbook
(XML access), a grayliner, internal QSL manager database support and a most
accurate country resolution algorithm based on country tables developed by
OK1RR. CQRLOG is intended for daily general logging of HF, CW & SSB contacts
and strongly focused on easy operation and maintenance.
Homepage: http://www.cqrlog.com

delete all lines. Save the file. Now try to install version 2.0.1.

I tried to install version 2.0.1 both on clean computer and also on a computer where previous version was installed and didn't have any problem :(.

73 Petr

DK1MAX
Thanks

... it works!

73... Max

DC0EV
DC0EV's picture
CQRLOG the same failure since before

Hi,I always get the same faliure about the Tmysql56connection.
I dont know,what I can do.
Quick help does not work.
I have Ubuntu 15.10

File: 

KB5IAV
I run Linux Mint 17.3 and

I run Linux Mint 17.3 and wanted to let you know it worked.

I removed the lines from the file and saved it. I ran the update module and it updated everything but CQRLog. What I did next was go into Synaptic and was able to install the new version from there. So far, it works!

73,

Jonathan, KB5IAV

un7pex
un7pex's picture
E: /var/cache/apt/archives

E: /var/cache/apt/archives/cqrlog_2.0.1-1~trusty_amd64.deb: подпроцесс новый сценарий post-removal возвратил код ошибки 1

(synaptic:5435): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
(Чтение базы данных … на данный момент установлено 193640 файлов и каталогов.)
Preparing to unpack …/cqrlog_2.0.1-1~trusty_amd64.deb ...
Unpacking cqrlog (2.0.1-1~trusty) over (2.0.0-1~trusty) ...
dpkg: предупреждение: подпроцесс старый сценарий post-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
dpkg: error processing archive /var/cache/apt/archives/cqrlog_2.0.1-1~trusty_amd64.deb (--unpack):
подпроцесс новый сценарий post-removal возвратил код ошибки 1
dpkg: ошибка при очистке:
подпроцесс новый сценарий post-removal возвратил код ошибки 1
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ошибка при установке пакета. Попытка восстановления:

Best regards, UN7PEX Dmitry!
73!

dk7ob
/etc/apparmor.d/usr.sbin.myqsld

Renamed for upload

File: 

dk7ob
/etc/apparmor.d/local/usr.sbin.myqsld,

Renamed for upload

File: 

dk7ob
Quick fix worked

Forgot to mention. The quick fix worked, see messages below (sorry for German messages). Thank you!

wofritz@eddie(11):/etc/apparmor.d$ sudo apt-get install cqrlog
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Das folgende Paket wurde automatisch installiert und wird nicht mehr benötigt:
extra-xdg-menus
Verwenden Sie »sudo apt autoremove«, um es zu entfernen.
Die folgenden NEUEN Pakete werden installiert:
cqrlog
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 0 B von 7.618 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 27,7 MB Plattenplatz zusätzlich benutzt.
Vormals nicht ausgewähltes Paket cqrlog wird gewählt.
(Lese Datenbank ... 255187 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cqrlog_2.0.1-1~xenial_amd64.deb ...
Entpacken von cqrlog (2.0.1-1~xenial) ...
Trigger für man-db (2.7.5-1) werden verarbeitet ...
Trigger für mime-support (3.59ubuntu1) werden verarbeitet ...
cqrlog (2.0.1-1~xenial) wird eingerichtet ...

Changes removed from /etc/apparmor.d/usr.sbin.mysqld

File /etc/apparmor.d/local/usr.sbin.mysqld was already modified, no changes needed

N2PAD
Quick fix confirmed

Hi Petr,

The quick fix worked, I now have CQRLOG 2.0.1 (2016-05-07) running.

Here are the contents of the apparmor files:

-------------------------------------------------------------------

/etc/apparmor.d/usr.bin.mysqld:

# This file is intensionally empty to disable apparmor by default for newer
# versions of MariaDB, while providing seamless upgrade from older versions
# and from mysql, where apparmor is used.
#
# By default, we do not want to have any apparmor profile for the MariaDB
# server. It does not provide much useful functionality/security, and causes
# several problems for users who often are not even aware that apparmor
# exists and runs on their system.
#
# Users can modify and maintain their own profile, and in this case it will
# be used.
#
# When upgrading from previous version, users who modified the profile
# will be promptet to keep or discard it, while for default installs
# we will automatically disable the profile.

------------------------------------------------------

/etc/apparmor.d/local/usr.bin.mysqld:

@{HOME}/.config/cqrlog/database/ r,
@{HOME}/.config/cqrlog/database/** rwk,

NZ0T
Fix worked!

Thank you!!

W2PAU
W2PAU's picture
The Fix Worked

Thank you Petr. I appreciate it.

73

Jim

DC0EV
DC0EV's picture
2.01 willnot install errors at installing

Hi,
that is what I get,when i try to install the last version of cqrlog.

73 from Guenter

File: 

ok7an
ok7an's picture
Re: 2.01 willnot install errors at installing

Hi Guenter,

could you send me what do you have in /etc/apparmor.d/usr.sbin.mysqld, please? Maybe there is the problem why apparomor didn't started correctly.

73 Petr, OK2CQR

DC0EV
DC0EV's picture
apparmor problem

Hi Petr,
the wanted file is empty!!

73 from Guenter