upload to LoTW not working

4 posts / 0 new
Last post
KG4AKV
KG4AKV's picture
upload to LoTW not working

Hi, First of all thank you for all the hard work on CQRLog. It really is great software.

I am using CQRLog 1.3.0 from the prebuilt binary on the website. I am on Fedora 16 x86_64 and using TrustedQSL packages from Fedora (not the ones built by Petr). I am able to upload logs successfully both manually (export logs from CQRlog and sign using tqsl) and by uploading the tq8 file generated/signed by CQRLog directly to the arrl lotw site. What I'm saying there is that I can take the tq8 files from /home/john/.config/cqrlog/lotw and go to arrl's lotw site and attach them and they work fine.

What doesn't work is the upload from within CQRlog. I even straced it and you can see the connection being made to the server, but for some reason it doesn't work:

Starting export to adif ...
Export to the adif file completed.
File:
/home/john/.config/cqrlog/lotw/2012-01-31_18-29-55.adi
Signing adif file ...
Signed ...
If you did not see any errors, you can send signed file to LoTW website by pressing Upload button

Uploading file ...
Size:
Error: 0

2012-01-31 23:25:50
2012-01-31 23:26:50
2012-01-31 23:27:50
2012-01-31 23:28:50
2012-01-31 23:29:50
select * from view_cqrlog_main_by_qsodate LIMIT 500 OFFSET 0

select * from view_cqrlog_main_by_qsodate LIMIT 500 OFFSET 0

/usr/bin/tqsl -d -l "Raleigh - Lundy Dr." /home/john/.config/cqrlog/lotw/2012-01-31_18-29-55.adi -x
DBPing - select * from cqrlog001.db_version

DBPing - select * from cqrlog001.db_version

2012-01-31 23:30:50
2012-01-31 23:31:50
2012-01-31 23:32:50
2012-01-31 23:33:50
2012-01-31 23:34:50
2012-01-31 23:35:50
2012-01-31 23:36:50
2012-01-31 23:37:50
DBPing - select * from cqrlog001.db_version

DBPing - select * from cqrlog001.db_version

2012-01-31 23:38:50

[john@aphrodite lotw]$ pwd
/home/john/.config/cqrlog/lotw
[john@aphrodite lotw]$ ls -l
total 20
-rw-rw-r--. 1 john john 1561 Jan 31 11:06 2012-01-31_11-06-39.adi
-rw-rw-r--. 1 john john 3020 Jan 31 11:06 2012-01-31_11-06-39.tq8
-rw-rw-r--. 1 john john 2836 Jan 31 18:29 2012-01-31_18-29-55.adi
-rw-rw-r--. 1 john john 4573 Jan 31 18:30 2012-01-31_18-29-55.tq8
[john@aphrodite lotw]$

Any ideas? You will notice that it shows no size, in the documentation a size is shown. I never get a size. Seems to be part of the issue. I have tried disabling SELinux but that didn't help either.

Here is the strace where you can see the tq8 file is opened and a connection is made to pk1.arrl.org

17983 19:57:02.909453 open("/home/john/.config/cqrlog/lotw/2012-01-31_19-56-54.tq8", O_RDONLY|O_LARGEFILE) = 15
17983 19:57:02.909671 flock(15, LOCK_SH|LOCK_NB) = 0
17983 19:57:02.909846 lseek(15, 0, SEEK_SET) = 0
17983 19:57:02.910016 lseek(15, 0, SEEK_CUR) = 0
17983 19:57:02.910163 lseek(15, 0, SEEK_END) = 4573
17983 19:57:02.910285 lseek(15, 0, SEEK_SET) = 0
17983 19:57:02.910412 read(15, "\37\213\10\0\0\0\0\0\2\3\315\231I\223\233\310\276\305\367|\212\336\23\267\231AT\370:\202y\6"..., 4573) = 4573
17983 19:57:02.910634 close(15) = 0
17983 19:57:02.910878 socket(PF_INET, SOCK_DGRAM, IPPROTO_IP) = 15
17983 19:57:02.911380 sendto(15, "\333\213\1\0\0\1\0\0\0\0\0\0\3p1k\4arrl\3org\0\0\1\0\1", 30, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("192.168.2.1")}, 16) = 30
17983 19:57:02.911647 select(16, [15], NULL, NULL, {5, 0}) = 1 (in [15], left {4, 997955})
17983 19:57:02.913992 recvfrom(15, "\333\213\201\200\0\1\0\1\0\r\0\0\3p1k\4arrl\3org\0\0\1\0\1\300\f"..., 524, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("192.168.2.1")}, [16]) = 257
17983 19:57:02.914275 close(15) = 0
17983 19:57:02.914462 socket(PF_INET, SOCK_STREAM, IPPROTO_TCP) = 15
17983 19:57:02.914793 connect(15, {sa_family=AF_INET, sin_port=htons(443), sin_addr=inet_addr("38.126.103.90")}, 16) = 0
17983 19:57:02.961169 getsockname(15, {sa_family=AF_INET, sin_port=htons(47973), sin_addr=inet_addr("192.168.2.200")}, [16]) = 0
17983 19:57:02.961418 getpeername(15, {sa_family=AF_INET, sin_port=htons(443), sin_addr=inet_addr("38.126.103.90")}, [16]) = 0
17983 19:57:02.961660 shutdown(15, SHUT_WR) = 0
17983 19:57:02.961893 nanosleep({0, 1000000}, 0x7fffcf7ed840) = 0
17983 19:57:02.963230 ioctl(15, FIONREAD, [0]) = 0
17983 19:57:02.963412 close(15) = 0

I'm not an export on unix sockets but I don't see any errors in that exchange. I guess next step would be to capture a tcpdump..

CQRLog is awesome! This is the only problem I've had so far.

ok2cqr
ok2cqr's picture
Re: upload to LoTW not working

Hello,

do you have libssl-devel rpm installed? I'm not sure if the name of the package is the same also in Fedora, but hope it is similar. This package is needed to sucessfull login to LoTW webstite.

73 Petr, OK2CQR

KG4AKV
KG4AKV's picture
I do not have anything called

I do not have anything called libssl or libssl-devel. However I found openssl-devel and that fixed it after I restarted CQRLOG.

Thanks Petr!

namboru (not verified)
not get it yet

I think I cant get it clearly, but thanks.
https://seohandal.id/jasa-seo/