CW type sending each character twice

4 posts / 0 new
Last post
KE1AZ
CW type sending each character twice

Hello,

I have ver 2.2.0 (001), running on Ubuntu 16, with a Winkeyer. Since the upgrade to the latest version, in CW Type, letter mode it sends each character twice, as in: CCQQ CCQQ. The "word mode, first word in letter mode" does not do this. I have used it for a long time (thank you!) and it did not do this until just now.

I tried powering the keyer off and on again, and getting out of CQRLOG and back in again but no change. Any suggestions appreciated.

Thank you,
Jim KE1AZ

oh1kh
CW type sending each character twice

Hi Jim!

This seems to be related to Lazarus version that is used to compile the source.
It looks like it is related to this bug https://www.cqrlog.com/node/1943

I did a test compile with my devel source and the official source using Lazarus 1.8.0 and got his "double letter" error for both when
"letter mode" is used in CW type window. The word mode works ok.

Then I tested with my test binary from http://www.saunalahti.fi/sakny/bin/cqrlog2/ that is compiled with lazarus 1.6.4.
It works ok in letter and word mode and also the bug https://www.cqrlog.com/node/1943 does not exist.

So if you need working "CW type" please try my test binary. It can just be copied over existing /urs/bin/cqrlog.

I think my next job will be downgrading my Lazarus back to 1.6.4 version.

--
Saku
OH1KH

KE1AZ
CW type sending each character twice

Thank you Saku. I shall try it tomorrow.

Regards, Jim ke1az

KE1AZ
CW type sending each character twice

Thank you again Saku. It worked great. Hope I can return the favor some day.

Regards,
Jim KE1AZ