CQRLOG 2.1.0 deb package for Raspberry Pi

12 posts / 0 new
Last post
WZ0W
WZ0W's picture
CQRLOG 2.1.0 deb package for Raspberry Pi

I've generated a .deb file to install CQRLOG on a Raspberry Pi. It installed OK on my Raspbian Jessie system on a Pi 3. You can get the file here: https://www.dropbox.com/s/pp613nzsqai7ond/cqrlog_2.1.0-1_armhf.deb?dl=0.

Enjoy,

Scott WZ0W

ok7an
ok7an's picture
Re: CQRLOG 2.1.0 deb package for Raspberry Pi

Thank you for great work, Scott!

Could I download the deb and put it to CQRLOG website into Download section, please?

73 Petr

WZ0W
WZ0W's picture
Absolutely! Glad to help.

Absolutely! Glad to help.

N7TOX
apt issues

Any tips on getting all the dependencies for this installed? I'm having major issues with getting the MySQL stuff to install cleanly. To be fair, this is the first time I've tried to seriously use at apt based distro (I'm a Gentoo man at heart), so maybe you just need to point me to a good tutorial somewhere. :)

N7TOX
Well, I seem to have fixed

Well, I seem to have fixed this. Somehow. At least, it's working now, after I properly initialized the mysql data dir with mysql_install_db.

WZ0W
WZ0W's picture
MySQL issues

Sorry...I didn't see your request for help. Not sure if have been much help. But there's a program called GDebi that will check dependencies and try to resolve them if possible.

Anyway, glad you got it sorted.

Scott WZ0W

sp9fkp
Dependencies

On my fresh RPI 3 installation with kernel 4.9.41 I must add default-libmysqlclient-dev

WZ0W
WZ0W's picture
Thank you

Thanks for letting me know. Were you able to get it running once you installed that package?

sp9fkp
All right

Off course, no more problems. Thank You.

73 - Piotr

IU1IPB
CQRLOG 2.1.0 for Raspberry Pi : problem with SSH connection

Hello Scott,

Great job, thank-you. I'm a bit curious to know how you succeed in building CQRLOG on PI (cross-compilation or building on Raspberry ?) : I tried but I failed due to Lazarus version error ...
In any case the installation on my PI was successful, excluding for the network connection to DX Cluster (both http and telnet : status connect but no spot flowing) and to LoTw (where I got an SSL "can't connect" error in sending adif file). Connection of the “grayzone” is on the contrary correctly running and I can see the reverse beacon spots.
Do you have any suggestion ? PI is PI3 fresh Jessie installation, up-to-date.
Thank-you
73 IU1IPB Ugo

WZ0W
WZ0W's picture
Building for Raspberry Pi

Ugo,
I built the package using an Ubuntu MATE image on the Raspberry Pi. This way I was able to use Petr's Lazarus and FPC packages in his PPA. Once the .deb package was generated, I copied it over to the SD card with Raspbian and installed it there.

I have been having these same issues with network components of CQRlog recently myself. I think something in a Raspbian update may have affected the networking aspects of CQRlog, but no idea what.

All the best,
Scott WZ0W

IU1IPB
Building for Raspberry Pi

Thank-you Scott, I will try to buld my myself on MATE.
By the way, a preliminary googling reports a case of "Network subsystem is unusable / open SSL" error from Lazarus forum, dealing with open SSL version issue.
Not totally sure to be able to solve by myself.

All the best,
Ugo