mode.......display on top of screen

15 posts / 0 new
Last post
f1mxe
mode.......display on top of screen

google traductor.
Good morning all,
I have a (small) problem with the display of qso mode.
I checked in the visible menu columns mode but I can not find this mode in the list of contacts at the top of the screen.
Thank you in advance if you have an idea.
sorry I can not send pictures to show the concern.
73 Didier F1MXE Jn05gq

bonjour à tous,
J'ai un (petit) problème avec l'affichage du mode du qso.
j'ai bien coché dans le menu visible columns mode mais je n'arrive pas à retrouver ce mode dans la liste des contacts, haut de l'écran.
Merci par avance si vous avez une idée.
désolé je n'arrive pas à envoyer des images pour montrer le souci.
73 Didier F1MXE Jn05gq

oh1kh
mode.......display on top of screen

Hi!
I think I have seen similar error here before.

Check this message chain: https://www.cqrlog.com/node/1920

--
Saku
OH1KH

ei2idb
I have very similar problem

Hi all,
In QSO list everything seems O.K. , I can see 'mode' column and others without any problem

But with previous qso's in New QSO window I have some problems: 'Mode' column is not visible, and please take a look at very strange 3rd column from right and the last one mysterious named 'Title":
https://www.cqrlog.com/sites/default/files/NewQSO.png

If I open a 3cqrlog.cfg file I can see this:

[frmNewQSO_dbgrdQSOBefore]
qsodate=83
time_on=60
callsign=87
freq=60
rst_s=60
rst_r=60
name=60
qth=60
qsl_s=60
qslr=60
country=60
\91\00\00\00\00\00\00\00x\00\00\00\00\00\00\00h\E7\FB\00\00\00\00\00\00\00\00\00\00\00\00\00x\DD\FB=60
loc=60

I tried few times to export, edit and import cfg file but without any effect - it always going back to the same.
Thanks in advance for any help with that.

File: 

<p>73!</p>
<p>Slav, EI2IDB</p>

oh1kh
I have very similar problem

Hi Slav!

Open the 3cqrlog.cfg again with text editor when cqrlog is running. Use "plain" text editor like vi, nano, leafpad etc. Not "too fine" editors like LibreOffice etc. they can cause unexpected results.
Remove the long line with lot of numbers away it causes the "dice" looking column as seen in your picture.
Then add a line with:

mode=60

Then save the edited file and close cqrlog. File disappears and contents are moved to database. On next opening database is read and file is recreated.
It should then have the "mode"-line and not that long line.

The export/edit/import has unfixed problems. If you want to do it that way you need to create a new log. And before opening it import the settings file.
See this: https://www.cqrlog.com/comment/6716#comment-6716

--
Saku
OH1KH

ei2idb
I have very similar problem

Hi Saku,
Tnx for answer and help.
I am using nano editor on my Ubuntu 18.04.
Just tried again what you wrote in your previous post but this long strange line always returning to 3cqrlog.cfg file. I am adding new line with mode=60 in section [frmNewQSO_dbgrdQSOBefore] but this line always disappear from file after closing cqrlog and starting again.
Is it possible that database is not updated after closing the cqrlog for any reason?

<p>73!</p>
<p>Slav, EI2IDB</p>

oh1kh
I have very similar problem

Hi Slav!

I looked at source code and now I can give procedure how to change config to existing log.

Open cqrlog
Select the log you want to change.
Check also that in "Database connection" window" "Open recent log at program start" is not selected
Open the log, remember log number.
Open folder ~/.config/cqrlog and find "log number"cqrlog.cfg (I.E. 1cqrlog.cfg if log 001 is in use)
Open file in plain text editor and change lines you need to change.
Save file with another name like fixed_cfg.ini (note the suffix changes from ".cfg" to ".ini")
Check also file "log number"local.cfg (I.E. 1local.cfg in case of log 001) in case you have set something to be saved locally. If the needed line(s) is(are) there: change and save. These settings do not go to database.
Close cqrlog.
Open again cqrlog
Select log that needs to be changed do not open log . Selected log should show out with blue background
Go to Utils/Configuration/Import
Navigate to find recently saved "fixed_cfg.ini"
Select file and press "Open" button.
"Config file imported successfully" should appear. Press "OK"
Open selected log. Changes from "fixed_cfg.ini" should be visible now.
Close cqrlog normally after use.

--
Saku
OH1KH

ei2idb
Working and done!

Saku,
Once again huge thank you for your help, for your time, for your patience and for your knowledge of cqrlog. Like others I really appreciate your support for cqrlog users community.

<p>73!</p>
<p>Slav, EI2IDB</p>

oh1kh
Working and done

My pleasure!
Enjoy cqrlog!

--
Saku
OH1KH

ei2idb
I have very similar problem

I have no idea if it's any connection to the problem but after closing cqrlog in debug mode I got:
(cqrlog:4723): Pango-WARNING **: 00:17:22.716: Invalid UTF-8 string passed to pango_layout_set_text()

<p>73!</p>
<p>Slav, EI2IDB</p>

f1mxe
Hello Saku,

Hello Saku,
i believe that it is the same problem. But i do not find the config files. using ubuntu 18.04 gnome.
sorry for not finding.
tks for your help, 73 Didier F1MXE

File: 

f1mxe
other picture

other picture

File: 

oh1kh
other picture

Hi!

Config file in /home/YOUR_USERNAME/.config/cqrlog folder exist only if cqrlog is running. It disappears when you close cqrlog.
Open cqrlog
Select log (note log number)
Open folder /home/YOUR_USERNAME/.config/cqrlog
It is hidden folder. There is a dot before word "config" that makes it hidden if your file browser settings are not set to show hidden files and folders.

if you use command console then when you open it you are at /home/YOUR_USERNAME folder
Then just type:
cd .config
and after that
cd cqrlog

Or both at same time
cd .config/cqrlog

with:
ls
you can see filenames. There is a file like
1cqrlog.cfg
Number is 1 if you have log number 1 open. If you have some other log open then the number refers to log number.

That is the file you should open with editor and check like in that other message chain says.

--
Saku
OH1KH

f1mxe
Hello Saku and thanks for

Hello Saku and thanks for your patience !
sorry for my stupidity but I can not save the line mode = 60 despite the use of gedit in admin mode: admin://
i can edit and add mode=60 but not save !
73
Didier F1MXE

the original part is:
[frmNewQSO_dbgrdQSOBefore]
qsodate=87
time_on=52
callsign=74
freq=67
rst_s=49
rst_r=63
name=74
qth=81
qsl_s=0
qsl_r=0
loc=107
qsl_via=60
dxcc_ref=87
remarks=60

oh1kh
Hello Saku and thanks for

--
Saku
OH1KH

f1mxe
good job, working fine now !

good job, working fine now !
Thanks Saku for your help.

73 Didier F1MXE