TELNET DX-Cluster freeze after Dist-Upgrade

5 posts / 0 new
Last post
DL2KI
TELNET DX-Cluster freeze after Dist-Upgrade

Hi,

after an upgrade from KUbuntu 18.04LTS to 18.10 no spots are displayed in the DX cluster window after a few minutes. The previous spot list "freezes".

The Telnet window is used with "telnet.reversebeacon.net" as "DX-Cluster". After restarting CQRLog, the spot display will work again for a few minutes before freezing again.

Disconnect and reconnect while CQRLog is running do not solve the problem. The login to the DX cluster is executed, but the spot is not displayed.

The problem only seems to affect the Telnet window.

What could be the cause?

Thank you in advance,
Wolfgang, DL2KI

oh1kh
TELNET DX-Cluster freeze after Dist-Upgrade

Hi!

>Disconnect and reconnect while CQRLog is running do not solve the problem. The login to the DX cluster is executed, but the spot is not displayed.
Do you get login prompt with reconnect? Or is it so that you just press connect/disconnect button, but nothing happens? That indicates you do not actually have reconnected.

Cqrlog telnet cluster is missing a check timer for connection. If connection fails because of internet, ethernet of Wifi failure, and you are not sending anything, just watching spots, you can not see the break from any indicator. Spots just stops to flow. The button (connect/disconnect) does not change.

First I would study the internet connection. Start command console and make telnet session manually to reversebeacon. Leave it running and start cqrlog's DXCluster too. When (if) Dxcluster at cqrlog fails does the command console telnet session still run ok?

These "after upgrade" failures can be mysterious, but checking the connection this way is a good start. If the failure is not there next it would be nice to know what have changed between 18.04 and 18.10. Specially network side.

--
Saku
OH1KH

DL2KI
Hi Saku,

Hi Saku,

unfortunately, at the moment I can only present the facts again, because I cannot recognize the cause. Maybe a problem with the compiler or the libraries? Are the spots buffered in CQRLog or passed on directly?

After Disconnect / Connect the login message appears. The display then stops.

Please enter your call:
Local users = 155
Current spot rate is 6384 per hour
DL2KI de SK1MMR-3 11-Jan-2019 08:27Z >

After restarting CQRLog, the spot display works, but freezes again after a few minutes (Or a certain number of spots?).

With the Telnet client on the command line, the spot display runs smoothly. There are no problems here.

After installing the CQRLog beta version, the same behavior occurs.

The same behavior was observed after installing the Kubuntu backports in October.
See my post "Kubuntu 18.04-LTS, information: Kubuntu Backports Issue".

So I first went back to version 18.04 LTS.
Here the Telnet DX cluster works again without problems.

Maybe a solution can be found.

73, Wolfgang
DL2KI

oh1kh
TELNET DX-Cluster freeze after Dist-Upgrade

HI!
Might be hard to find if console telnet works, but cqrlog telnet freezes.
Must be a library problem, but where?

Spots are passed directly. But do not go through if frequencies are set to zero. See:https://www.cqrlog.com/comment/7123#comment-7123
But this can't be same reason.

It could be some kind of tcp stack overflow. But on the other hand it should happen also with console telnet.
Sorry but this seems to be too rare and complicated problem to resolve "as remote".

--
Saku
OH1KH

DL2KI
Hi,

Hi,

yes, I can't find a solution to that either. At the moment I will stay at 18.04 LTS.

The problem seems to be an isolated one so far.

73, Wolfgang
DL2KI