cqrlog on kubuntu 18.04

8 posts / 0 new
Last post
dl1kfl
cqrlog on kubuntu 18.04

installed the recent ppa version ubuntu on a new system. Old configs and logs were rsynced to the new machine. Database is not configured to be in mysql.

Starting wsjtx in remote mode works, but after the first qso is logged, a window 'Access violation' appears on top of cqrlog and nothing more happens. No logging at all.

Any help would be appreciated.
73
dl1kfl

ok7an
ok7an's picture
Re: cqrlog on kubuntu 18.04

Hi,

I'm sorry, I don't use WSJTX but remember that recent version doesn't work correctly when the CQ monitor window is not shown. Do you have this windows visible?
Saku, OH1KH, who developed interface to WSJTX, will know more.

73 Petr OK7AN

dl1kfl
wsjtx

Hi Petr,

there is no window CQ-Monitor. However, I swapped back to 2.2.0(104) which works with wsjtx 1.9.1.

73, DL1KFL

oh1kh
wsjtx

Hi!
Load suitable zip 64 or 32bit from my web site: http://www.saunalahti.fi/~sakny/bin/cqrlog2/

Briefly: you just need to replace cqrlog binary file of your system. Weeery easyyyyy !
There is installation instruction file. Read it first.

If you do not like ready compiled binary (for security reasons) you can compile all by your self from my github: https://github.com/OH1KH/cqrlog-devel

Replacing binary should fix this kind of problem

--
Saku
OH1KH

oh1kh
wsjtx

Hi!

Just to inform you that you have to have wsjt remote ON.
After that you will have a selection "Window/Wsjtx monitor" if remote is OFF you do not see that selection.

That happens in all versions.

--
Saku
OH1KH

dl1kfl
Hi,

Hi,
this version works for me. First start: No qso dates and unknown date format. Disappeared after restart. Online/offline checkbox is confusing me. in wsjtx remote it is red showing offline. W/o wsjtx logging SSB qso it has to be changed to enter end-qso time.

In my opinion a great program. Logging first but no interceptions in what operator does.

73

73, DL1KFL

oh1kh
Nice to hear !

Nice to hear !

I have seen "unknown date format" few times(less than 10 times in past year), but never could catch the reason. The splash is showing date just same format as it should be.
When that happens and you press OK to continue then even qso typed in from new qso window does not go in. It just gives the same error all the time until restart. After that all goes on normally.

Online/offline checkbox indicates that qso date/time is coming outside of cqrlog. In this case from remote connect (while cqrlog/new qso itself is offline). You check that checbox also when you want enter a qso with past time and/or date. Otherwise (online) cqrlog will take date and time from PC clock at the time "Save QSO" is pressed.

You should log wsjtx qso using wsjtx's logging window. Either by pressing "log" button at main screen or put "settings/reporting/Prompt me to log qso" so that wsjtx will pop up logging window when you send 73 message.
Never log wsjtx qso by pressing "Save qso" at cqrlog's NewQso window !
Do not be confused if NewQso shows mode like SSB. It will be fixed when you press OK at wsjtx logging window. As well as qso start and also end times are recorded from wsjtx logging. You can check this afterwards from cqrlog's window/qso list. Just allow "time on" and "time off" from preferences/Visible columns.

--
Saku
OH1KH

dl1kfl
Closed

Thank you very much for the info.
Currently version 2.3.0(103) works great.

73
DL1KFL

73, DL1KFL