Error Executing Query TMySQL57 Connection

23 posts / 0 new
Last post
wn3lif
Error Executing Query TMySQL57 Connection

Just completed a rather fun day with WSJTX on FT-8.

Exited and requested a QSO list from CQRLOG.

Received the error in the attached image.

Ubuntu Version 18.04

CQRLOG 2.3.0 (101) 2018-06-19

wn3lif
Image for TMySQL57 Error

Had a little problem with the image upload.

File: 

wn3lif
Further information

I created a new log and still received the same error.

Worked fine 15 hours ago.

I did do a patch update after I received the error just be sure but still get the error.

73
WT
WN3LIF

wn3lif
Debug Output attached

Sorry I should have put this in the first time. Rushing...

Here is the output from running cgrlog with debug=1

Cqrlog Ver:2.3.0 (101) Date:2018-06-19
**** DEBUG LEVEL 1 ****

SSL libraries:
/usr/lib/x86_64-linux-gnu/libssl.so.1.0.0
/usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0
Loading libmysqlclient: /usr/lib/x86_64-linux-gnu/libmysqlclient.so.20
**************************
MySQL version: 5.7
**************************
**********************************
MySQL version assigned: 5.7
**********************************
Loaded 118377 LoTW users
Loaded 115544 eQSL users
Loaded 40133 SCP calls
*
User home directory: /home/wtj1/
Program home directory: /home/wtj1/.config/cqrlog/
Data directory: /home/wtj1/.config/cqrlog/database/
Memebers directory: /home/wtj1/.config/cqrlog/members/
ZIP code directory: /usr/share/cqrlog/zipcodes/
Binary dir: /usr/bin/
Share dir: /usr/share/cqrlog/
TConnection to MySQL: 5.7
*
56 us states loaded
/usr/sbin/mysqld --defaults-file=/home/wtj1/.config/cqrlog/database/mysql.cnf --datadir=/home/wtj1/.config/cqrlog/database/ --socket=/home/wtj1/.config/cqrlog/database/sock --port=64000
Trying to connect to database
TMySQL57Connection : Server connect failed.
Trying:1
Trying to connect to database
TMySQL57Connection : Server connect failed.
Trying:2
select * from tables where table_schema = 'cqrlog_common'

SELECT log_nr,log_name FROM cqrlog_common.log_list order by log_nr

use cqrlog003

use cqrlog003

use cqrlog003

use cqrlog003

use cqrlog003

SELECT * FROM cqrlog_config

select * from db_version

[UpgradeMainDatabase] Old version: 15 cDB_MAIN_VER: 15
select * from cqrlog_common.db_version

SELECT * FROM cqrlog_common.dxcc_ref ORDER BY ADIF

SELECT * FROM cqrlog_common.dxcc_ref ORDER BY ADIF

Settings:
-----------------------------------------------------
RigCtldPath:/usr/bin/rigctld
RigCtldArgs:-m 1 -r -t 4532
RunRigCtld: FALSE
RigDevice:
RigCtldPort:4532
RigCtldHost:localhost
RigPoll: 500
RigSendCWR: FALSE
RigId: 1

1
2
3
4
5
6

Settings:
-----------------------------------------------------
RotCtldPath:/usr/bin/rotctld
RotCtldArgs:
RunRotCtld: FALSE
RotDevice:
RotCtldPort:4533
RotCtldHost:localhost
RotPoll: 500
RotId: 1

rotctld started!
Connected to localhost:4533
FreqmemSql:select id,freq,mode,bandwidth from freqmem order by id

FreqmemFirst:0 FreqmemLast:0
CW init
SELECT * FROM profiles WHERE visible > 0 ORDER BY nr

SELECT * FROM profiles WHERE nr = 1

SELECT * FROM profiles WHERE visible > 0 ORDER BY nr

SELECT * FROM profiles WHERE nr = 1

select locator from profiles where nr = 1

select locator from profiles where nr = 1

1-FN21CI;Duryea PA;
select * from view_cqrlog_main_by_qsodate where qsodate >= '2018-07-07' order by qsodate,time_on

LoadForm: frmNewQSO
select * from view_cqrlog_main_by_qsodate LIMIT 500 OFFSET 0

LoadForm: frmMain
SELECT COUNT(*) FROM cqrlog_main

select count(*) from (select distinct adif from cqrlog_main where adif <> 0 and (adif not in ())) as foo

TApplication.HandleException TMySQL57Connection : Error executing query: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '))) as foo' at line 1
Stack trace:
$0000000000918EAF
$000000000091A598
$000000000044AB66
$0000000000431F6F
$0000000000656B2D
$000000000044CD42
$0000000000662958
$0000000000654561
$0000000000654491
$0000000000450849
$0000000000652867
$000000000066D91C
$000000000066A37E
$000000000044A5BB
$000000000044F71C
$00000000004F64FE
$00000000006B006A
1
2
3
4
5
6
Closing DXCluster window
Closing TRXControl window
Closing GrayLine window
Closing dDXCC
Deleting config file: cqrlog.cfg
Deleting config file: 3cqrlog.cfg
Closing dData
/home/wtj1/.config/cqrlog/database/epasec.pid
Command:
kill 2049
WARNING: TMenuItem.Destroy with LCLRefCount>0. Hint: Maybe the component is processing an event?

File: 

km4hqe
Error Executing Query TMySQL57 Connection

I'm seeing the same thing here. Maybe it's because it's Friday the 13th :)

I could of swore I downloaded the latest source and built it, but help and about shows I have version 2.2.0 (001) 2018-04-21 I'm running Kubuntu 18.04

If I click Ok and continue, the QSO list doesn't have some of my recent QSO's :( I do have it set to backup on exit, so maybe they are in a backup.

73

Stan
KM4HQE

wn3lif
mysql.err

mysql.err log attached.

File: 

oh1kh
mysql.err CAN BE IN DXCC INFO UPDATE; DO NOT ACCEPT LATEST YET

Hi all !

I do have this same error when requesting QSO list window.

Now I ask:
Do you have accepted to download new dxcc/qslmgr when you started cqrlog?
It seems to be related to this latest update.

I do not know yet how, but I did accept that and session before that worked ok.

I will check if restoring older ~./config/cqrlog/ctyfiles folder from other computer and reading into cqrlog will help

--
Saku
OH1KH

km4hqe
mysql.err CAN BE IN DXCC INFO UPDATE; DO NOT ACCEPT LATEST YET

Hi Saku,

Yes, unfortunately, I did the update. I'll try restoring the ctyfiles and one of the recent backups later today.

Thanks for your help!

73

Stan
KM4HQE

oh1kh
!!! DO NOT ACCEPT NEW QSLMGR UPDATE AT START !!!!!

Hi!

Problem seems to be in QSLMGR update file if it is accepted at program start.

Managed to make my log work when I copied ~./config/cqrlog/ctyfiles folder from PC that I did not have accepted latest update.

Copy forder from that PC to /tmp
Open cqrlog and QSO list window. Say OK to errors so that you can continue.
open: QSO list window / FIle / Import / DXCC data
Navigate into folder /tmp/ctyfiles , first file will be highlighted press OPEN

Importing will happen.

Close cqrlog and start again. DO NOT ACCEPT UPDATE DXCC/QSLMGR !!!!
Open QSO list.
No errors should be seen.

Worked for me, but while repeating these several times to pinpoint error I lost all preferences from my log.
Seems that qsos are there still. I have to look it next...

But if you do this once it works, so not try to make further investigations by accepting updates at program start until we know that update is fixed.

In case you do not have older ctyfiles folder I uploaded cty.zip to my web page: http://www.saunalahti.fi/~sakny/bin/cqrlog2/
extract it to your /tmp folder.

REMEMBER! YOU TRY THIS QUICK FIX ON YOUR OWN RESPONSIBILITY !

--
Saku
OH1KH

dk7ob
Thanks for looking at it!

Hi Saku,

I saw a lot of QSOS lost in the data base and also in the backup adif files.

So I recovered with a backup from June 28 (i should do backups more often, I know..) and the last good adif backup file from the corrupted data base. I only had to enter the 3 last QSOS manually (they were on Clublog).

Nevertheless I wanted to try your solution, but while moving the corrupted data base back I managed to erase it :-( So I can not check, would have been interesting to see whether the lost QSOs were back.

Meanwhile I disabled the check for new DXCC files / managers until the issue is resolved.

km4hqe
!!! DO NOT ACCEPT NEW QSLMGR UPDATE AT START !!!!!

Since I build from source, I imported the ambiguous.tbl file using Import DXCC data from the QSO list window, restarted, said no to the update and opened the log file I had been using. Looks like my last QSO is in the list, so I guess it's back the way it was before the update. Although I don't recall how many QSO's were in the list to know if it might have deleted any.

Thanks!

73

Stan
KM4HQE

wn3lif
Seems that the QSLMGR or DXCC file is the culprit

After reading all the posts and trying to figure out where things were going I did my own experiment.

Rather straight forward. Moved the cqrlog config directory out of the way.

Used Synaptic to remove CQRLOG and then install it again. Just to get a clean starting point after all that file moving and downloading.

Recreated my logfile, DID NOT ACCEPT THE QSLMGR & DXCC UPDATE, recreated my preferences, imported my ADIF backup, and all is well. Now I just have to import the FT8 entries that I made while waiting to see what greater minds than mine came up with as a root cause.

Many thanks to the CQRLOG guys for all the hard work. Sincerely appreciate everything.

73
WT
WN3LIF

AG5OV
Possible cause of some of this

I posted my own issue that may be related to what you all are seeing. I had to reload my ham box and had hell getting CQRLOG installed, tried most of what is here, reload MySQL, reload the InnoDB stats tables, reloaded CQRLOG and 101 patch, blew away .config/cqrlog, reloaded from ADIF, etc.

Finally noticed what I show in my topic:

https://www.cqrlog.com/node/2094

Everything has worked since then, I -think- I even loaded the DXCC update by accident after this, but I'm not sure as it it's asking me to update it on startup anymore.

73
Rob AG5OV

wn3lif
Saw the missing date

Rob,

I saw that missing date too. I put a date in but it didn't solve the issue. So I just decided that up and running was better for me than trying to debug the problem.

I'll let the CQRLOG guys do that.

73!
WT
WN3LIF

ok7an
ok7an's picture
Re: Error Executing Query TMySQL57 Connection

Hi,

the problem is in country tables with KH1. There is a quick fix:

go to .config/cqrlog/ctyfiles
open Country.tab file in your favourite text editor
find KH1|Baker & Howland Islands|OC|12|0.194722N|176.479444W|61|31|20||
change it to
KH1|Baker & Howland Islands|OC|12|0.194722N|176.47W|61|31|20||
save the file
Run CQRLOG, ignore the error message, to to QSO list File->Import -> DXCC data and point to .config/cqrlog/ctyfiles directory

it will import fixed coutry tables and cqrlog will work again.

I'm very sorry for the bug.

n8cd
n8cd's picture
That fixed it

Thanks for the post - that fixed it for me!

km4hqe
Error Executing Query TMySQL57 Connection

Hi Everyone,

Seems like we created a few message threads on what looks like the same issue. So far, it looks like restoring the ambiguous.tbl file from the 2.2.0/2.3.0? source tarball has fixed the problem for me. I've selected NO to both updates when CQRLOG starts and things seem to be back to normal.

Yes, best to wait on the CQRLOG folks for a definite solution.

Yes, many, many thanks for CQRLOG. There isn't a lot of logging software for Linux. All around, I think CQRLOG is right up there with the DXLab Suite on windows.

Just wish we had a good contest logger. JL is/was great, but the author seems to no longer support it. I've hacked on it some, but it's written in JAVA and I have a bit of a learning curve in order to make any progress with that.

Hope to work some of you in the IARU HF contest this weekend.

73

Stan
KM4HQE

ok7an
ok7an's picture
Hi Stan,

Hi Stan,

please try this solution:

https://www.cqrlog.com/comment/6635#comment-6635

73 Petr

oh1kh
Hi Petr

Just wondering why country KH1 effects this?

In my tests I found that if I accept QSLmgr update then the error started. And that update does not contain country file.
At the moment my "fixed" log offers just qslmgr update, no dxcc. If I accept that mysql errors start again.

More errors than KH1 in updates?

--
Saku
OH1KH

ok7an
ok7an's picture
Re: Hi Petr

Hi Saku,

QSL managers are in separate table, dxcc tables are the most importatnt because cqrlog does left join to that table.

I just also fixed the DXCC tables, this update will fix the issue.

73 Petr

oh1kh
Re: HI Saku

OK.
Thanks!

Original dumps of the fault pointed to adif, so I also first thought it was in dxcc updates. After pinpointing several times the updates and side effects I made conclusion that it must be in qslmgr.

But no wonder I was wrong. Joining tables may make thinks look different in this case. Doing this fault update few times and then resetting ctyfiles again resulted finally that I missed all preferences from my log !?!?!

The main thing is that it is fixed !

--
Saku
OH1KH

km4hqe
Hi Stan,

Hi Petr,

I misstated what I did. I copied all of the files in the ctyfiles directory from the source tarball, then I imported the table file. My Country.tab file has what you suggested to change KH1 to. Things are running fine, but I haven't chosen to do any updates when CQRLOG has prompted me.

73

Stan
KM4HQE

yo4fzv
Thanks

Well done.
Fixed now.
Thanks.
73 de Laur