Cqrlog fails to connect to database. Does not load or run past intro screen

13 posts / 0 new
Last post
K5KV
Cqrlog fails to connect to database. Does not load or run past intro screen

When cqrlog is opened the screen with the bug and version show and the log selector box comes up with a third box that server connection did not work.
 
Today 1.81 came in and was installed.  Then the computer locked up.  No response from keyboard or mouse.  FInally killed computer with power button.  After that cqrlog will not run.  i forced back to version 1.73 and still would not run.  then upgraded to 1.81 again and same results.  it cannot connect to the database server or whatever that is.
 
complete dismantle here to take down desk and put station on new table being delivered tomorrow.  this could not have come at a worse time.
 
any help would be appreciated.
73
BENNY K5KV

K5KV
ERROR DURING CONNECTION TO DATABASE: SERVER CONNECT FAILS

THERE HAS TO BE A BETTER WAY BUT I HAD NO CHOICE DUE TO TIME PRESSURE.
DOING A COMPLETE UNINSTALLOR REMOVAL OF CQRLOG WITH SYNAPTIC AND RENAMING THE REMAIINING CQRLOG DIRECTORY UNDER .CONFIG TO "OLDCQRLOG" AND THEN A COMPLETE NEW INSTALLATION FINALLY GOT CQRLOG WORKING AGAIN.
 
MAYBE A FUTURE VERSION WONT LOCK UP LIKE THIS?
 
73
BENNY K5KV

n1ea
Benny,

Benny,
 
I have the same problem.  I cannot connect to the database.  This leaves CQRLOG completely unusable.
I tried to connect to localhost which is 127.0.0.1 with a username of cqrlog and password is BLANK that is nothing for a password.  These were the default settings - these must have been set automatically when cqrlog installed.
I press Connect and I receive this message: "Error during connection to database: Server connect failed."
I don't know if it is just a bug - as your message says - or a possible corruption of the database file.
 
This program should automatically backup the database if it is that important.
I have NOT done what you suggest, but I am running cqrlog Version=1.7.4
(gdb) runStarting program: /usr/bin/cqrlog warning: Could not load shared library symbols for linux-gate.so.1.Do you need "set solib-search-path" or "set sysroot"?[Thread debugging using libthread_db enabled]Using host libthread_db library "/usr/lib/libthread_db.so.1".**** DEBUG LEVEL 0 ******** CHANGE WITH --debug=1 PARAMETER ****[New Thread 0xb5f7cb40 (LWP 22915)][Thread 0xb5f7cb40 (LWP 22915) exited][New Thread 0xb5f7cb40 (LWP 22916)][New Thread 0xb4e77b40 (LWP 22917)]
I hope this is helpful to the authors.
 
73
David N1EA
 
 
 
 

K5KV
CQRLOG CANNOT CONNECT TO DATABASE!! HOW TO FIX?

CQRLOG IS DEAD AGAIN WITH "CANNOT CONNECT TO DATABASE".  CAN SOMEONE PLEASE TELL ME NOW TO FIX THIS WITHOUT A COMPLETE NEW INSTALL?

ok7an
ok7an's picture
Re: CQRLOG CANNOT CONNECT TO DATABASE!! HOW TO FIX?

Hi Benny,
 
please look at ~/.config/cqrlog/database/mysql.err file. There will be more information.
 
161, Petr

wc2l
Sounds similar to my issues.

Sounds similar to my issues. Petr, I sent you an email with the info you asked for.
WIll WC2L

ok7an
ok7an's picture
Re: Sounds similar to my issues.

Hi Will,
 
I alredy sent you an email with solution. This is only for other users who could have the same problem.
This is interesting part of ~/.config/cqrlog/database/mysql.err:
 
InnoDB: Error: log file ./ib_logfile0 is of different size 0 50331648 bytesInnoDB: than specified in the .cnf file 0 5242880 bytes!
 
To solve this problem, open ~/.config/cqrlog/database/mysql.cnf and just after [mysqld] add this:
 
innodb_log_file_size=50331648
 
Save the file and run CQRLOG.
 
It seems this have something to do with different default MySQL configuration in different distributions.
 
73 Petr, OK2CQR
 

m0ddr
No mysql.cnf

<p>I have the same problem. I couldn't even find that file on my system.</p>

m0ddr
<p>oops!!! I found the file

<p>oops!!! I found the file mysql.cnf and added the line suggested. Now I'm being told the database won't start and is it installed properly.</p>

m0ddr
I went back to mysql.cnf and

I went back to mysql.cnf and removed the earlier line.

When I loaded cqrlog I get a simple database window but still cannot create a log. I tried to use log No1 and m0ddr but I get the reply "Error executing query Table cqrlog_main already exists" &nbsp; It makes no difference if I log to the local machine or not.

I looked at the error log but it might as well be in Chinese, I cannot understand what it is trying to tell me.

K5KV
CANNOT CONNECT TO @#$%^ DATABASE UPDATE

I BACKUP MY ENTIRE "DATABASE" DIRECTORY AFTER I SHUTDOWN CQRLOG WITH THE UBUNTU BACKUP.  MY COMPUTER LOCKED UP ON MAR 3.  I RESTORED THE "DATABASE" DIRECTORY TO MARCH 1.  CQRLOG RUNS AGAIN AND I ADDED A FEW MISSING QSOS FROM ADIF EXPORT AND IT WORKS AGAIN.  THEN UPDATED TO 1.9.0.
 
THE RESTORE BACK TO MARCH 1 WIPED OUT ALL MYSQL.ERR FILE DATA FROM MARCH 1 TO MARCH 5.  GONE. I HAVE DATA FOR MARCH 1 AND MARCH 5 ONLY.  MYSQL.ERR DOES NOT SHOW THE DATES NEEDED.
WHAT IS THE FILE OR FILES THAT NEED TO BE RESTORED TO MAKE CQRLOG WORK AGAIN WHEN IT CANT FIND THE DATABASE?
73
BENNY K5KV

on3nad
same here on debian 8

same here on debian 8

Error during connection to database: Server connect failed.

strange , but luckyli it is in the repositories so that's better than deb9 :)

any tips on getting him over first start ?

on3nad
never mind fixed it

never mind fixed it