Permanent bug when Statistics, DXCC Statistics , Rebuild DXCC statistics

5 posts / 0 new
Last post
F6GOX
Permanent bug when Statistics, DXCC Statistics , Rebuild DXCC statistics

Hello,

Enter a new qso, so "country" field gives the good answer.

Then
- open window qso list => good "country" field
- Menu Statistics, DXCC statistics, Rebuild DXCC statistics
After rebuild => the new qso dxcc "country" field always will be transform in "Puerto Rico" ?...

now "Edit qso", so the fields:
dxcc ref kp4
waz 8
itu 11
and dxcc info window concerns Puerto Rico...

Trying several times with different qso and dxcc, reloading data, closed program and computer... for the same results : KP4 is the winner !

An idea ?
73 Laurent

ok7an
ok7an's picture
Re: Permanent bug when Statistics, DXCC Statistics , Rebuild DXC

Hi Laurent,

thank you for the bug report. I'll look at it.

73 Petr

oh1kh
Re: Permanent bug when Statistics, DXCC

Hi!

This seems to be interesting, but not permanent bug.

If I understood this "Enter a new qso, so "country" field gives the good answer." right it means QSO_list-window's column "DXCC_ref".

If I enter new qso the "DXCC_ref" shows right country. If I then run Menu->Statistics->DXCC statistic-> Rebuild DXCC statistics" the result of latest qso's DXCC_ref will change.

For me it changed first to SP. When adding few more qsos it started to change to F.

If I take the latest qso back to edit the DXCC_ref will turn back to right country corresponding to callsign.

But this happens only once at first time !!

If I save edit, when DXCC_ref is again ok. Rebuild DXCC statistics again; it turns back to F (at the moment).
Then if I again take it to Edit the "DXCC_ref" will NOT any more change to right country, but stays as F.

--
Saku
OH1KH

G4AFU
DXCC rebuild/statistics

Same problem here. I have imported from previous .adi my log VP8STI (South Sandwich) and VP8SGI (South Georgia). CQRLog shows both as Falkland so I changed them to correct entity and did DXCC rebuild. No change, still shows as Falkland. If I filter log for both calls they show as correct entity in logbook. Paul G4AFU

ok7an
ok7an's picture
Re: DXCC rebuild/statistics

Could you run cqrlog from console and send here the output, please. Run it just using cqrlog without --debug=1. If there is any problem during the rebuild, it will be noticed in the console.