CQRLOG 1.4.1 released

After a few days new version of CQRLOG. Thanks to Jeff, K4LMP and Darek, SP2MKI I've fixed TRX control. Now it's working as expected (hopefully). New version is already uploaded into Lauchpad and is building right now. More at http://www.cqrlog.com/download

I'm sorry but for the mean time, only Ubuntu 12.04 and Debian Unstable are officially supportted. For older Ubuntu version you can try debs for Precise but no guaranties. If it won't work, please use cqrlog binaries.

I'm very sorry, but for now, I'm not able to support all older releases. I'll try to force lauchpad to build cqrlog for older Ubuntu but not sure if it will be possible.

Comments

Very nice piece of software.

Hi Petre,

CQRlog is a nice piece of software, tks indeed for your efforts to make it better and better.

Best 73 and GL.

CT1DRB
David Quental

k8wdx's picture

Agree 100% Tom K8WDX BTW

Agree 100% Tom K8WDX

BTW don't forget the Donate tab to the right. Peter needs some coffee!!

ka1oz's picture

Cannot get to Preferences with 1.41

GM, Petr--

Just upgraded to 1.41 and now find that I get an error message when attempting to get to menu item File-Preferences:

Error reading lbPreferences.ScrollWidth: Unknown property: "ScrollWidth".

Have a good day!

Preferences - error message

GM all,

I get the same message after upgrading to 1.4.1 on Ubuntu 10.10

73, enjoy the week-end on air
Pier IK1RDN

Preferences - error message

Same here: 1.4.1 errors out with Error reading lbPreferences.ScrollWidth: Unknown property: "ScrollWidth" when choosing preferences. Using Ubuntu 10.04 LTS 64 bit.

RE

I have the same problem in Linux Mint 10 (Maverick repos used). Debian package cannot be installed because there is library libgtk2.0-0 problem (>= 2.24.0 needed, 2.22.0 is in repo). Any idea? Josef OK2WO

same here

I tried debian package 1.4.1-1 but same problem on Ubuntu 10.10:
Error: Dependency is not satisfiable: libgtk2.0-0 (>= 2.24.0)
73,
Andrea 9a3jh

ok7an's picture

Re: same here

Hello Andrea,

please download directory with cqrlog binary from Recent version section. I did a mistake and can't build cqrlog for ubuntu maverick and older.
I'm very sorry.

73 Petr, OK2CQR

k8wdx's picture

Hi Peter, I know you are

Hi Peter, I know you are busy, here is a couple of bug reports, Mint 12.0, CQRlog 14.1-1,
I can no longer access Preferances, I get the error report priviously reported, this was not a problem with 14.0, also when I double click on a cluster spot, frequency display in CQRlog goes to 124.444 or something like that and stays there I have to restart the program to clear it. Is there a distro you recomend I use? this shack PC is just for Ham radio, so it does not matter what distro is on this one, would Ubuntu 12.04 be better?? TU de K8WDX

Hi Petr - Is the version

Hi Petr - Is the version available on the website different from the one in your repository? Because I installed from repository. If I try to download and install the .deb file directly from the website there is an unsatisfied dependency: libgdk-pixbuf2.0-0 which apparently does not exist in the repositories for lucid (10.04). To install the earliest available version of this package (for 11.04) quickly leads to dependency hell. Any suggestions? Thanks, I know you are busy. - Dan AE3E

ok7an's picture

Re: Hi Petr - Is the version

Hi Dan,

problem is with Lazarus version. In repo for Lucid there was version 0.9.30.1 and in Precise is 0.9.30.2. I didn't noticed that and used version from Precise to work on CQRLOG. This version doesn't work on Lucid. And if I compile cqrlog in Lucid, you got the message about ScrollWidth.

The only solution right now is download the tar.gz file with completely cqrlog directory, unpack it into your home folder and use it. I'm sorry, I don't have any other solution.

Petr

No problem

Thanks Petr, no problem, I was planning on updating the entire machine to Precise sometime in the future, this just hastens the day! Thanks again, Dan

ok7an's picture

Re: Cannot get to Preferences with 1.41

Hello Dick and Pier,

I'm sorry but it seems I can't build cqrlog for Ubuntu 10.10 because of old Lazarus version in my repo. I added it almost one year ago and don't remember how I did it. I tried quickly to find out without any success. In the mean time, please download deb file for Debian. It should work as well.

73 Petr, OK2CQR

ka1oz's picture

1.41.1 takes care of the Preferences problem

Petr--

Thanks for the astoundingly fast repair of the program!! I can now get to Preferences without any trouble.

CQRLOG is an example of the best of Open Source Software; with vibrant community response and amazingly quick resolutions to any problems that crop up.

Congratulations for a very fine job!

preferences

Thanks Petr!

73 de Pier IK1RDN