CQRLOG 1.4.0 released!

New version is here. Changelog is quite long, two bugs have been fixed, a few new features added. The most important change is new TRX control that use rigctld. Ubuntu packages are already on Launchpad created for Lucid, Maverick, Natty, Oneiric and Precise.
More: http://www.cqrlog.com/download

Comments

CQRLOG 1.4.0 released!

Hi Petr,

Wunderbar! Everything seems to be working so well. I have not tried all the features yet but congratulations on fixing all my woes.

tnx es 73,

Graeme ZL2APV

Two minor bugs found

Thanks again for fast upgrade, when Ubuntu version was changed to 12.04.

I have found 2 minor bugs.

In DXCC statistics the number of confirmed countries in mode table (phone, CW, etc.) is always the same than the number of total confirmed countries rather than for each mode separately. I didn't notice that in earlier cqrlog versions.

In TRX control window the rig names were not changed, when I entered the rigs in the new TRX control (rigctld) tab in Preferences. TRX control worked fine but the names were wrong. I have entered the rigs in the older version, and now I wanted to change their order, but was not able to do that.

73, Pekka oh2bsc

1.4

hello,

thanks Petr for the new version, working well with UBUNTU 12.04 !

Best regards

Didier F1MXE

G8FXM's picture

Cant get rigctld to work with FT2000

Since the upgrade I can no longer connect my FT2000 to CQRLog via rigctld (wasn't using rigctld previously). Anyone else have this problem, if anyone out there has managed to get their FT2000 working via rigctld, I'd be grateful if you could share you settings. I'm using Mint 12 here, but doubt that makes a difference.

k8wdx's picture

No rig control FTDX 5000

Hi Peter, set up a pc with Ubuntu 12.04, no rig control with CQRlog or Fldigi. here is the terminal window report. any Ideas?? Tom K8WDX
BTW I am using a USB adapter this pc has no serial ports, it does have the FD chip..

tom@tom-HP-Pavilion-P6000-Series:~$ cqrlog
Loading libssl: /usr/lib/x86_64-linux-gnu/libssl.so
Loading libcrypto: /usr/lib/x86_64-linux-gnu/libcrypto.so
Loading libmysqlclient: /usr/lib/x86_64-linux-gnu/libmysqlclient.so.18.0.0
Loaded 51684 LoTW users
Loaded 61141 eQSL users
*
User home directory: /home/tom/
Program home directory: /home/tom/.config/cqrlog/
Data directory: /home/tom/.config/cqrlog/database/
Memebers directory: /usr/share/cqrlog/members/
ZIP code directory: /usr/share/cqrlog/zipcodes/
Binary dir: /usr/bin/
Share dir: /usr/share/cqrlog/
*
/usr/sbin/mysqld --defaults-file=/home/tom/.config/cqrlog/database/my.cnf --default-storage-engine=MyISAM --datadir=/home/tom/.config/cqrlog/database/ --socket=/home/tom/.config/cqrlog/database/sock --skip-grant-tables --port=64000 --key_buffer_size=32M --key_buffer_size=4096K
120430 20:42:20 [Note] Plugin 'FEDERATED' is disabled.
120430 20:42:20 InnoDB: The InnoDB memory heap is disabled
120430 20:42:20 InnoDB: Mutexes and rw_locks use GCC atomic builtins
120430 20:42:20 InnoDB: Compressed tables use zlib 1.2.3.4
120430 20:42:20 InnoDB: Initializing buffer pool, size = 128.0M
120430 20:42:20 InnoDB: Completed initialization of buffer pool
120430 20:42:20 InnoDB: highest supported file format is Barracuda.
120430 20:42:20 InnoDB: Waiting for the background threads to start
120430 20:42:21 InnoDB: 1.1.8 started; log sequence number 1595675
120430 20:42:21 [Warning] Can't open and lock time zone table: Table 'mysql.time_zone_leap_second' doesn't exist trying to live without them
120430 20:42:21 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
120430 20:42:21 [ERROR] Native table 'performance_schema'.'events_waits_current' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'events_waits_history' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'events_waits_history_long' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'setup_consumers' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'setup_instruments' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'setup_timers' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'performance_timers' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'threads' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_thread_by_event_name' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_instance' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'events_waits_summary_global_by_event_name' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'file_summary_by_event_name' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'file_summary_by_instance' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'mutex_instances' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'rwlock_instances' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'cond_instances' has the wrong structure
120430 20:42:21 [ERROR] Native table 'performance_schema'.'file_instances' has the wrong structure
120430 20:42:21 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.5.22-0ubuntu1' socket: '/home/tom/.config/cqrlog/database/sock' port: 64000 (Ubuntu)
select * from tables where table_schema = 'cqrlog_common'

SELECT log_nr,log_name FROM cqrlog_common.log_list order by log_nr

use cqrlog001

use cqrlog001

SELECT * FROM cqrlog_config

select * from db_version

SELECT * FROM cqrlog_common.dxcc_ref ORDER BY ADIF

SELECT * FROM cqrlog_common.dxcc_ref ORDER BY ADIF

huu1
huu2
In create
All objects created
huu3
huu4

Settings:
-----------------------------------------------------
RigCtldPath:/usr/bin/rigctld
RigCtldArgs:-m %m -r %r -t %t -s 38400
RunRigCtld: TRUE
RigDevice: dev/dev/ttyUSB0
RigCtldPort:4532
RigCtldHost:localhost
RigPoll: 1000
RigSendCWR: FALSE
RigId: 129

Starting RigCtld ...
/usr/bin/rigctld -m 129 -r dev/dev/ttyUSB0 -t 4532 -s 38400
rig_open: error = IO error
rigctld started!
Result0:N
Result1:Y
Result2:Y
Connected to localhost:4532
Loading window size a position (height|width|top|left):651|807|24|49
Section:frmQSODetails
Loading window size a position (frmQSODetails) (height|width|top|left):210|266|24|49
CW init
SunDelta:-3.999800000000000000E+00
SELECT * FROM profiles WHERE visible > 0 ORDER BY nr

SELECT * FROM profiles WHERE visible > 0 ORDER BY nr

2012-05-01 00:42:24
SELECT * FROM profiles WHERE visible > 0 ORDER BY nr

SELECT * FROM profiles WHERE visible > 0 ORDER BY nr

SELECT * FROM profiles WHERE visible > 0 ORDER BY nr

no rig control FT-897

Unfortunately under cqrlog rig control doesn't work with my Yaesu FT-897. (Under gnome predict rigctld is ok).

I will be glad if there will be old method connecting to rig again. Ofcourse selectable by user in preferences. I think that it will be very helpful for other users too.

Below some info about my case.

Polling seems to be ok. It is strange bacause message from command line shows proper frequency and mode from rig, but there is an error RPRT -11 (function not supported?). Finally no frequency and mode from rig in cqrlog. Below output from cqrlog and verbose messages from rigctld started manually (rigctld --model=123 --serial-speed=4800 -r /dev/ttyUSB0 --set-conf=stop_bits=2 -vvvv)

============ cqrlog ================
huu0
1
2
3
4
5
6
huu1
huu2
In create
All objects created
huu3
huu4

Settings:
-----------------------------------------------------
RigCtldPath:/usr/bin/rigctld
RigCtldArgs:-m %m -r %r -t %t -s 4800 -vv
RunRigCtld: FALSE
RigDevice: /dev/ttyUSB0
RigCtldPort:4532
RigCtldHost:localhost
RigPoll: 1000
RigSendCWR: FALSE
RigId: 123

rigctld started!
Result0:N
Result1:Y
Result2:Y
Connected to localhost:4532
Could not get freq from radio:14255000
USB
0
RPRT -11

Could not get freq from radio:14255000
USB
0
RPRT -11

Could not get freq from radio:14254300
USB
0
RPRT -11

Could not get freq from radio:14247100
USB
0
RPRT -11

Could not get freq from radio:14241900
USB
0
RPRT -11

Could not get freq from radio:14232900
USB
0
RPRT -11

Could not get freq from radio:14232600
USB
0
RPRT -11

================== rigctld ===========

rigctld, Hamlib 1.2.10
Report bugs to

rig:rig_init called
rig: loading backend yaesu
yaesu: initrigs2_yaesu called
rig_register (121)
rig_register (127)
rig_register (110)
rig_register (105)
rig_register (106)
rig_register (107)
rig_register (109)
rig_register (120)
rig_register (101)
rig_register (122)
rig_register (123)
rig_register (111)
rig_register (115)
rig_register (113)
rig_register (114)
rig_register (128)
rig_register (116)
rig_register (103)
rig_register (124)
rig_register (104)
rig_register (125)
rig_register (129)
rig_register (130)
rig_register (117)
rig_register (119)
rig_register (118)
rig_register (126)
ft897:ft897_init called
rig:rig_open called
ft897:ft897_open called
Opened rig model 123, 'FT-897'
Backend version: 0.3.3, Status: Beta
Connection opened from 127.0.0.1:33190
ft897: cache invalid
ft897: using cache (0 ms)
ft897: cache timed out (978 ms)
ft897: using cache (0 ms)
ft897: cache timed out (977 ms)
ft897: using cache (0 ms)
ft897: cache timed out (974 ms)
ft897: using cache (0 ms)
ft897: cache timed out (977 ms)
ft897: using cache (0 ms)
ft897: cache timed out (974 ms)
ft897: using cache (0 ms)
ft897: cache timed out (977 ms)
ft897: using cache (0 ms)
ft897: cache timed out (974 ms)
ft897: using cache (0 ms)
ft897: cache timed out (977 ms)
ft897: using cache (0 ms)
ft897: cache timed out (974 ms)

============

no rig control FT-897

Thank You for fast answer!

I use 32-bit version. Can I download fixed 32-bit version for testing too?

Rafal
sq7ota

Re: no rig control FT-897

Hello

Thank You for helping. Changed executable to new one and rig control doesn't work. Info from command line:

Settings:
-----------------------------------------------------
RigCtldPath:/usr/bin/rigctld
RigCtldArgs:-m %m -r %r -t %t -s 4800 -vv
RunRigCtld: FALSE
RigDevice: /dev/ttyUSB0
RigCtldPort:4532
RigCtldHost:localhost
RigPoll: 1000
RigSendCWR: FALSE
RigId: 123

rigctld started!
Result0:N
Result1:Y
Result2:Y
Connected to localhost:4532
Whole MSG:|RPRT -5
|
a[i]:RPRT -5
Whole MSG:|RPRT -5
RPRT -11
|
a[i]:RPRT -5
a[i]:RPRT -11
Whole MSG:|RPRT -5
|
a[i]:RPRT -5
Whole MSG:|RPRT -5
RPRT -11
|
a[i]:RPRT -5
a[i]:RPRT -11
Whole MSG:|RPRT -5
|
[..]

Re: no rig control FT-897

Sorry Petr, my mistake - rig control works! (I noticed that I changed cat rate in radio to bad value 38400).

Thank You again!

I detected new problem: starting preferences dialog fails (ctrl-p). I think this is tiny bug.
"Ok to continue(risk data corrupt.), Cancel(stop program)".
Command line:
TApplication.HandleException Error reading lbPreferences.ScrollWidth: Unknown property: "ScrollWidth"
Stack trace:
$0818629A
$081854AB
$0817C92B
$08185212
$08185535
$0817C92B
$08186CCD
$081E71F3
$081E7054
$081E0167
$08082BCF
$08084DF9
$080D75EA
$0817DB62
$08271508
$080DA119
$0825283D

ka1oz's picture

No rigctld on my machine...where to get?

Hi Petr--

I have not been able to run TRX Control since ungrading to 1.4. I cannot find rigctld on my PC and cannot figure out where to get it.

Am running Ubuntu 11.10. Please help!

ka1oz's picture

libhamlib-utils did the trick!

Thank Petr--

I was disappointed when the updated version just sat there, but now I'm back on track! Your quick response got be going again quickly. Thanks!

rigctld + ubuntu 11.10 + IC-756PRO3 + Microham USB Interface III

Hi all.

My problem was, that after starting the rigctld daemon up, TRX started immediately transmit, so I must use "--set-conf=dtr_state=OFF,rts_state=OFF" option.
So, my complete command line arguments for rigctld are:
-m 357 -r /dev/ttyUSB0 -s 19200 -c 0x6E -t 4532 --set-conf=dtr_state=OFF,rts_state=OFF

Hope, should be usefull for someone.

Duro, OM0XA

rigctld not working with my IC-718

I use IC718 connected via FTDI USB to RS232. Xubuntu 12.04. Fldigi works fine via FTDI interface in hamlib CAT mode. Spent couple of hours trying to set CQRLog CAT. Command line parameters: -m 313 -r /dev/ttyUSB1 -s 4800 -c 0x5E -t 4532 --set-conf=dtr_state=OFF,rts_state=OFF. IC718 CIV speed set to 4800 and CIV address to 0x5E. I am a member of dialout group. What could be wrong?
vy 73 de YT1DL

-----------------------------

-----------------------------------------------------
RigCtldPath:/usr/bin/rigctld
RigCtldArgs:-m 313 -r /dev/ttyUSB1 -s 4800 -c 0x5E -t 4532 --set-conf=dtr_state=OFF,rts_state=OFF
RunRigCtld: TRUE
RigDevice: /dev/ttyUSB1
RigCtldPort:4532
RigCtldHost:localhost
RigPoll: 500
RigSendCWR: FALSE
RigId: 313

Starting RigCtld ...
/usr/bin/rigctld -m 313 -r /dev/ttyUSB1 -s 4800 -c 0x5E -t 4532 --set-conf=dtr_state=OFF,rts_state=OFF
rig_open: error = IO error
rigctld started!
Result0:N
Result1:Y
Result2:Y
Connected to localhost:4532
Loading window size a position (height|width|top|left):651|807|189|257
CW init
SunDelta: 2.000100000000000000E+00
SELECT * FROM profiles WHERE visible > 0 ORDER BY nr

SELECT * FROM profiles WHERE visible > 0 ORDER BY nr

2012-05-15 10:52:44

I am sure. Have two but I am

I am sure. Have two but I am sure this one is right because Fldigi works with same settings. Also, if I do not set '--set-conf=dtr_state=OFF,rts_state=OFF' IC718 switch to TX during CQRLOG load.

I found a problem! Must set

I found a problem! Must set IC-718 start up parameter CIV TRN to off.
Thank you anyway...73..good luck...