CQRLOG 1.0.0~beta1 released

It's about 3 weeks since latest release. I've fixed a lot of bugs. Please install this new version and do some tests. If you find any problem or have any idea, please let me know.

News:
  • Close button to ADIF import window added
  • "Complete" will appear after ADIF import finish
  • hamlib dependencies fixed
  • after swith to another log TRX control in New QSO window stoped working - fixed
  • Transaction already active error in Mark QSL function fixed
  • after changing frequency in Preferences -> Bands program crashed - fixed
  • import of QSLS_DATE and QSLR_DATE damaged values - fixed
  • after select different DXCC entity for station program crashed - fixed
How to upgrade from version 1.0.0~alpha2
If you use deb package, just install new version. Nothing more. If you use tar.gz version, delete old version and create new directory for 1.0.0~beta1.

How to upgrade from version 0.9.6 or older
It is described in article about CQRLOG 1.0.0~alpha1 release.

Packages for Ubuntu 10.04 and newer:




Complete application directory for other distributions:


It should work at any distribution but don’t forget to install MySQL server, MySQL client and hamlib libraries, first.

If you’ll find a bug or will have a suggestion please let me know here to the CQRLOG’s forum or send me an email to petr@ok2cqr.com. I have also jabber and my jabber address is petr@ok2cqr.com (I have my own jabber server). Thank you.

Comments

DXCC statistics

at first, you did a good job. the ADIF import now works perfectly.
I see something strange in the DXCC statistics. If a QSO is confirmd by LOTW a QSL-confirmation is ignord. In the statistics this county is marked with an 'X' instead of 'Q' But on the DXCC stat in the 'New QSO' window it is displayd correct with a 'Q'

73 de Uwe (DH1UZ)

Sort (F7) stoped to "EA3"

Hey. I tried to sort my QSOs by Call. Sort shows QSOs to prefix letters EA3 only. I cannot see QSOs EA4 to ZZ QSOs. What have I done wrong? Distro is Ubuntu 11.04 with the lastest updates. I do not use any filters in sorting QSOs. 73s de Timo OH7JHA

k8wdx's picture

Awards, LOTW

Ok, 2 questions, # what is the "Award" on the main screen for? what type of info should go in there. #2 If I want the LOTW users to be identified, on the cluster, is there not some sort of file that needs to be downloaded? and if so Where should it be downloaded to? If this is not the case, how does the program know who is a LOTW user, BTW this does not seem to work, I turned the marker to yellow, so far no yellow calls, Thanks, BTW this is a great program, I don't really use clusters to much, but just like to know how things work and if they really do. I am one of those that if it is available I like it to work,so I am checking everything, even if I do not plan to use it. Thanks for all your effort...

DK5TX's picture

Three little bugs

Hi Petr,

installation and ADIF import works flawlessly. I've identified 3 bugs on Ubuntu 11.04 with the "Classic" Desktop (which means Gnome 2.32.1):

1.
In the Ubuntu 11.04 standard installation the scrollbar has a new layout, called "hidden scrollbar" or so. The scrollbar is just a very small bar which gets an additional up/down or left/right button when the mouse gets over it. This can be grabbed with the mouse and pushed up/down/left/right to scroll the entries. Unfortunately this does not work in the QSO list (CTRL-O) or the upper section of the New QSO window (scrolling not possible). Also the mousewheel and up/down keys on the keyboard are not working flawlessly here on my PC. But if this ridiculous hidden scrollbar is disabled (http://tinyurl.com/5r2tk8f) and Gnome shows the old-fashioned scrollbars again everything works fine.

2.
If I want to delete DX Cluster entries from the "Choose dxcluster" diaglogue I get an error like this:
http://imageshack.us/photo/my-images/651/deletingdxc.png
Adding DX clusters is possible and the DX cluster itself works fine.

3.
When I want to sign & upload QSOs to LoTW I get this error:
http://img215.imageshack.us/i/tqslerror.png/
CQRLOG started from a terminal shows me this command which seems to cause the error:
/usr/bin/tqsl -d -l "Detmold" /home/su/.config/cqrlog/lotw/2011-05-03_13-48-27.adi -x 2>
If I delete the "2>" from this line and enter it into terminal everything works fine.

Apart from this not much testing so far. Will check more details (TRX control etc) soon.

73
Ulf DK5TX

k8wdx's picture

WAZ

I think the WAZ is refered to the CQ zone, right?, Just want to let you know, if this is the case I put in my own call and got WAZ 4, AND MY CQ zone is 5, This is not the only logging program that gets this incorrect.. Check it out, my call is K8WDX. Thanks for such a nice logging program, I am now 100% Linux user.

k8wdx's picture

QTH area

Does it matter what goes in the QTH field? will this effect any of the filtering, should I leave it default. just want to know, I am thinking of just putting in the country there, like to see that when I look at my log sheet, BTW that would be a nice addition, to have a country field added, again thanks for the nice logging software...

Lost connection to MySQL server during query

I'm using the latest Ubuntu 11.04 with Unity desktop. Installation of 1.0.0~beta1 went smoothly and also the transfer of the log. Everything seems to be working flawlessly, but randomly I get the following error message (pop-up window):

MainCon : Error executing query: Lost connection to MySQL server during query.

Press OK to ignore and risk data corruption.
Press Cancel to kill the program.

I don't use MySQL for any other application than this. I have re-installed the server from Ubuntu repository, but it didn't help. I haven't been able to find any pattern when this error appears. Any ideas? Has anyone else encountered the same error?

Pekka OH2BSC

MySQL error

I have also experienced the same error during qso
query on several occasions as well as a few times
when the program has been left running for an
extended period.

Richard KY7Q

ok7an's picture

Re: MySQL error

Hi Pekka and Richard,

truhth is, I have the same problem. But as I can observe there is no regularity. Sometimes I've benn running cqrlog for couple of hours and no crash, sometimes it crashes after 20 minutes.
I made two changes. CQRLOG uses threads for dxcluster, bandmap etc. DXcluster needs connection to database so now dxcluster thread has its own database connection. The second is database ping. Every 8 minutes cqrlog send small sql query to database server and it refresh connection and should prevent any crashes because of inactivity. So I hope these changes will help.

73 Petr, OK2CQR